mirror of
https://github.com/kanidm/kanidm.git
synced 2025-04-21 09:45:39 +02:00
Some checks are pending
Linting checks / clippy (push) Waiting to run
Linting checks / fmt (push) Waiting to run
Spell Check / codespell (push) Waiting to run
Container - Kanidm / Set image tag values (push) Waiting to run
Container - Kanidm / Build kanidm Docker image (push) Blocked by required conditions
Container - Kanidm / Push kanidm Docker image (push) Blocked by required conditions
Container - Kanidmd / Set image tag values (push) Waiting to run
Container - Kanidmd / Build kanidmd Docker image (push) Blocked by required conditions
Container - Kanidmd / Push kanidmd Docker image (push) Blocked by required conditions
Container - Radiusd / Set image tag values (push) Waiting to run
Container - Radiusd / Build radius Docker image (push) Blocked by required conditions
Container - Radiusd / Push radius Docker image (push) Blocked by required conditions
Javascript Linting / javascript_lint (push) Waiting to run
Javascript Linting / javascript_fmt (push) Waiting to run
GitHub Pages / pre_deploy (push) Waiting to run
GitHub Pages / fanout (${{ needs.pre_deploy.outputs.latest}}) (push) Blocked by required conditions
GitHub Pages / docs_master (push) Waiting to run
GitHub Pages / deploy (push) Blocked by required conditions
PyKanidm tests / tests (push) Waiting to run
Linux Build and Test / rust_build (push) Waiting to run
Linux Build and Test / rust_build_next (beta) (push) Waiting to run
Linux Build and Test / rust_build_next (nightly) (push) Waiting to run
Linux Build and Test / run_release (push) Waiting to run
Windows Build and Test / windows_build_kanidm (push) Waiting to run
The existing shell.nix uses whatever versions of rustc and cargo are in the system nixpkgs. In the current stable nixpkgs version (24.11), this is rustc 1.82.0. Unfortunately, we depend on the `strict_provenance` feature, which was unstable before 1.84.0. (See: kanidm/concread#132) This patch makes minimal changes to shell.nix to overlay nixpkgs with the rustc version defined in rust-toolchain.toml, enabling Kanidm to build locally on stable versions of NixOS. Co-authored-by: Firstyear <william@blackhats.net.au>
24 lines
605 B
Nix
24 lines
605 B
Nix
let
|
|
rust-overlay = (import (builtins.fetchTarball "https://github.com/oxalica/rust-overlay/archive/master.tar.gz"));
|
|
in
|
|
{ pkgs ? import <nixpkgs> { overlays = [ rust-overlay ]; } }:
|
|
pkgs.mkShellNoCC {
|
|
# Kanidm dependencies
|
|
buildInputs = with pkgs; [
|
|
pkg-config
|
|
|
|
(rust-bin.fromRustupToolchainFile ./rust-toolchain.toml)
|
|
|
|
clang
|
|
llvmPackages.bintools
|
|
|
|
openssl
|
|
] ++ pkgs.lib.optionals (pkgs.stdenv.isLinux) [
|
|
systemd
|
|
linux-pam
|
|
];
|
|
|
|
# https://github.com/rust-lang/rust-bindgen#environment-variables
|
|
LIBCLANG_PATH = pkgs.lib.makeLibraryPath [ pkgs.llvmPackages_latest.libclang.lib ];
|
|
}
|