mirror of
https://github.com/kanidm/kanidm.git
synced 2025-02-22 20:26:30 +01:00
25 lines
544 B
Nix
25 lines
544 B
Nix
{ pkgs ? import <nixpkgs> {} }:
|
|
let
|
|
overrides = (builtins.fromTOML (builtins.readFile ./rust-toolchain.toml));
|
|
in
|
|
pkgs.mkShellNoCC rec {
|
|
# Kanidm dependencies
|
|
buildInputs = with pkgs; [
|
|
pkg-config
|
|
|
|
cargo
|
|
rustc
|
|
|
|
clang
|
|
llvmPackages.bintools
|
|
|
|
openssl
|
|
] ++ pkgs.lib.optionals (pkgs.stdenv.isLinux) [
|
|
systemd
|
|
linux-pam
|
|
];
|
|
|
|
RUSTC_VERSION = overrides.toolchain.channel;
|
|
# https://github.com/rust-lang/rust-bindgen#environment-variables
|
|
LIBCLANG_PATH = pkgs.lib.makeLibraryPath [ pkgs.llvmPackages_latest.libclang.lib ];
|
|
} |